Modern Warfare 2

MIC doesn't work ingame ( MW2 )

Reply to this topic Start new topic
# 1sowfast551 Sep 14 2011, 19:48 PM
Playing MW2 on a PC. Tested mic on steam and it works great. But when I start MW2 and go to options ingame to test the mic I use the Z-button to talk it doesn't work. I can't talk to no-one ingame. I'm running Windows XP Pro if that helps. I went to steam website and found this info not sure how to find this on my PC.


This is from steam:

Microphone input switches when launching a game
Question
I have all the recording settings for my mixer and select Line 1/Mic, and it works before I play a game, but whenever I start CS it sets the recording device to Wave Out Mix, instead of Line 1/Mic. As a result the game engine is binding it's mic input to the wrong source on the sound card.

I can alt-tab out of the game and set it back to Line 1/Mic then it works for the test in the options menu, but when I join a Server it puts it the mic back to Wave Out Mix again so my mic won't work.

How do I fix this?

Answer
Other software applications like CD Recording programs can change the wavein input to come from the CD player instead of from the microphone, then when players try and use their microphone in the game it won't work.

To solve this, the HL engine tries to make sure the mixer control settings are set properly when the game runs, but not all soundcards work the same way, especially very high-end sound cards like Audigy 2ZS pro cards.

To prevent the HL engine from trying to set the mic input, players need to set this CVAR in their userconfig.cfg file or in the launch properties of the game.

Add this line in userconfig.cfg:

voice_forcemicrecord 0

or in the launch properties for each game you play:

+voice_forcemicrecord 0

(you don't need both)

This will prevent the engine from attempting to configure the mixer settings.

You might also check and make sure these settings are correct:

voice_enable "1"
sv_voiceenable "1"
voice_scale "0.75"
voice_dsound "1"
voice_modenable "1"

By default, these settings will be found under the following directory:
C:\Valve\Steam\SteamApps\<Steam Account Name>\<Game Title>\<Abbreviated Game Title>\cfg\config.cfg

If this file does not exist you may create it by creating a new Notepad document in the \cfg\ folder, entering the suggested settings, and renaming the file to "config.cfg

Not sure if this is the problem or not.
Can anyone plz help me get the mic to work rite for me ingame. THX Very Much

Posts: 1

+

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)