Explore GameReplays...

Kanes Wrath

Beware of AMD's Newest Drivers!

Reply to this topic Start new topic
# 1Masterleaf Jan 2 2018, 16:41 PM
EDIT: AMD seem's to be working on a hotfix and with a bit of luck it might even address the graphical corruption.
https://www.reddit.com/r/Amd/comments/7nnc5...in_in_upcoming/

So as someone who experienced problems with AMD drivers in Kanes Wrath at the beginning of last year (graphics glitches to be precise) I opted to sell my card in the mining craze and buy a Nvidia card instead. I was hopeful that one day the drivers would get fixed and CNC games would be rendered properly again. HOWEVER that did not turn out to be the case. In fact the situation has worsened and now with AMD's newest "Adrenalin" driver you will be UNABLE to launch ANY sage engine game. The games NO LONGER WORK.

If anyone here is looking to buy a computer then for the love of god do not buy AMD, go with Nvidia as it seems they're the only gpu manufacturer with dx9 support nowadays. For AMD card owners now you will need to downgrade your drivers from this point onwards as CNC will no longer work!

This is an issue that has populated on reddit and AMD forums lately, KW and cnc3 tw is in the spotlight, though for all the wrong reasons. The video (timestamp is 09:00) and reddit links below will provide more information.



https://www.reddit.com/r/Amd/comments/7nmzj...witcher_cc_and/

IPB Image


This post has been edited by Masterleaf: Jan 2 2018, 17:56 PM

Posts: 1,199

Game: Kanes Wrath


+
# 2Zypherbullet Jan 2 2018, 17:08 PM
Thanks for the warning, mister Leaf smile.gif.

Posts: 7,596

Clan: FeaR

Game: Kanes Wrath


+
# 3AggressivePanda Jan 2 2018, 17:24 PM
[center]IPB Image


Posts: 8,293

Clan: FeaR

Game: Kanes Wrath


+
# 4AggressivePanda Jan 2 2018, 17:30 PM
On the contrary: https://twitter.com/CatalystMaker/status/948224999726501890

Posts: 8,293

Clan: FeaR

Game: Kanes Wrath


+
# 5PANIC^.-B4rTgF Jan 2 2018, 17:32 PM
Yeh I've experienced the same with my 480rx, no trouble the 1060

Posts: 1,005

Game: Kanes Wrath


+
# 6Masterleaf Jan 6 2018, 13:47 PM
I find it amazing how AMD bothered to address this as these games have an insignificant number of players playing them. They went out of their way to install CNC3 on their test machines in 2018 and urgently patch the issue with an emergency driver update. A lot of faith in AMD has been restored after hearing this news for me. They seem to care a lot about backwards compatibility after all.
On a side note, could anyone with one of their graphics cards test to see if the texture glitches still persist with the new alpha driver?

Source: http://www.pcgamer.com/amd-releases-an-alp...squash-dx9-bug/

The alpha driver for those with AMD graphics cards: http://support.amd.com/en-us/kb-articles/P...ease-Notes.aspx

This post has been edited by Masterleaf: Jan 6 2018, 13:53 PM

Posts: 1,199

Game: Kanes Wrath


+
# 7Claymore92 Jan 6 2018, 14:24 PM
They don't care about backwards compatibility at all.

"I opted to sell my card in the mining craze and buy a Nvidia card instead". Your words. This is why they're doing it. Not because they care about backwards compatibility, but to prevent income losses. Obviously, if they did not address this issue, any player who still plays or intends to play dx9 games would avoid AMD, which would affect their sales.

If they cared about backwards compatibility, statements like these would not exist: "This title is from 2007, so we are unlikely to devote any valuable engineering resources to this issue, which is most likely caused by outdated API modules."

What they care about is money, not backwards compatibility, unless backwards compatibility affects money. Then they care about it, because it affects income.

This post has been edited by Claymore92: Jan 6 2018, 14:27 PM

Posts: 613


+
# 8Dimitery Jan 6 2018, 14:38 PM
QUOTE(Claymore92 @ Jan 7 2018, 00:24 AM) *

They don't care about backwards compatibility at all.

"I opted to sell my card in the mining craze and buy a Nvidia card instead". Your words. This is why they're doing it. Not because they care about backwards compatibility, but to prevent income losses. Obviously, if they did not address this issue, any player who still plays or intends to play dx9 games would avoid AMD, which would affect their sales.

If they cared about backwards compatibility, statements like these would not exist: "This title is from 2007, so we are unlikely to devote any valuable engineering resources to this issue, which is most likely caused by outdated API modules."

What they care about is money, not backwards compatibility, unless backwards compatibility affects money. Then they care about it, because it affects income.


pretty much this, there should never have been an issue with backwards compatibility in the first place but now that it is effecting their income stream they are fixing it smile.gif

Posts: 2,429

Game: Kanes Wrath


+
# 9Masterleaf Jan 6 2018, 15:32 PM
Well in any case its still good how they pinned this at the top of their agenda. I really didnt see that coming. The only affected games are literally cnc3 ra3 bfme and witcher 1. Maybe if it werent for witcher they wouldnt care, however what they did here for a small minority is something that deserves credit. Sales wouldnt be affected because their officially supported dx9 titles like wow and sc2 will always be without issues. This was just to avoid bad PR and do something morally right.

Posts: 1,199

Game: Kanes Wrath


+

1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)