Explore GameReplays...

CNC Zero Hour

Connecting to players

Reply to this topic Start new topic
# 1Cougar3811 May 19 2015, 23:50 PM
Please read through... I have the same issue posted on these forums but have tried the XP Service Pack 3 setting as well as running in admin, along with others. We are really stuck and frustrated...
http://www.gamereplays.org/community/index...howtopic=962583

C&C Generals Zero Hour

We started by running through C&C Online launcher - multiplayer - then per forums to GenTool_v7.0.exe. With each of the programs we could see others in lobbies including the person I wanted to play with - we can get in the same lobby and launch a game - my bar loads, his does not - on his end his loads and mine does not - when the game starts, after about 1 minute of waiting on the connection screen, neither of us can move a unit or build, move, etc. This will go on until the games are closed (using Task Manager).

Sometimes he will get a vote option to kick me, and if he does he can then move and build but I am in the same frozen state. I can only pan the map but see no movement even when he is building things after I am "kicked". If I stay in game he can continue to play but if I exit my game he is defeted automatically (I set up lobby).

The only way to close my game each and every time I try to connect to him is to exit to desktop and use Task Manager to kill the application. The same is true for my friend, unless he gets the "kick" option, then he can exit normally.

I even set up Port Forwarding for UDP 16000 as was suggested online (don't think it was on this site) but that didn't help. Is Port Forwarding needed? Am I the server or are we both connecting to an actual server?

We have shut down all firewalls to ensure no connection issues, run as Administrator, with Windows XP Service Pack 3, and tried port forwarding.

I know people use this for playing Zero Hour tournaments so I can't figure out why we can't simply connect to eachother and play. I have read through a ton of posts on these forums and C&C Online and tried different things but no luck actually playing with my buddy.

Can you please help us?

Posts: 1


+
# 2xezon May 20 2015, 18:54 PM
It is a common issue. Please read faq http://www.gamereplays.org/cnczerohour/por...amp;tab=8280900

Posts: 23,469

Clan: MENTAL

Game: CNC Zero Hour


+
# 3ober93 Nov 15 2020, 22:52 PM
I have the exact same issue, im trying to play with my brother (both have windows 10, Command&conquer ZH from Origin, and have installed Gentool 8.0 + GenPatcher 1.1) We executed the game on compatibility mode (Windows XP SP3) and Fullscreen. We go into multiplayer, we can se each other con network, create a party, both can join (If i create he can connect, If he creates i can connect as well) No problems so far, but then we tried to play, I can see the loading bar from both charging, but he cant, then the game starts only for me (he is still on the loading screen despite his loading bar is full, he cant see mine)
So we tried the other way around (He is the host now) and we have the same issue. I can see him loading but he can not see me. So this must be a connection problem? Should i try another VPN? Im currently using "Radmin VPN" and used before for others games without problems

Posts: 1


+
# 4xezon Nov 15 2020, 23:23 PM
Maybe you need to set Port Override in Game Options menu to different numbers.

Posts: 23,469

Clan: MENTAL

Game: CNC Zero Hour


+
# 5nestorsk Jul 27 2021, 05:51 AM
QUOTE(ober93 @ Nov 15 2020, 22:52 PM) *

I have the exact same issue, im trying to play with my brother (both have windows 10, Command&conquer ZH from Origin, and have installed Gentool 8.0 + GenPatcher 1.1) We executed the game on compatibility mode (Windows XP SP3) and Fullscreen. We go into multiplayer, we can se each other con network, create a party, both can join (If i create he can connect, If he creates i can connect as well) No problems so far, but then we tried to play, I can see the loading bar from both charging, but he cant, then the game starts only for me (he is still on the loading screen despite his loading bar is full, he cant see mine)
So we tried the other way around (He is the host now) and we have the same issue. I can see him loading but he can not see me. So this must be a connection problem? Should i try another VPN? Im currently using "Radmin VPN" and used before for others games without problems



u solved it?

Posts: 2


+

2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)