Printable Version of Topic

Click here to view this topic in its original format

GameReplays.org _ GenTool Support Forum _ Black screen BUG

Posted by: OlegBB Oct 14 2019, 07:36 AM

Hello

While playing generals solo ( with PC ) on screen resolution 2560*1440 (2k) and if i look at place where a lot of unit i got black game screen ( see attached file ) . i can move screen to empty place and view will be back to normal. IF i repeat and move screen to place where many units it became black again while concentration unit on this place not decrease : (

i tried with minimal setting but with resolution 2560*1440 (2k) - same result

but on full HD 1920*1080 with max settings can not reproduce this BUG.


Could you plesae investigate and help


Windows 10 x 64 , i7 3770, 32 GB , 1050ti
Gentool 7.8 (same on 7.7)


Thanks


Attached thumbnail(s)
Attached Image

Posted by: xezon Oct 14 2019, 10:19 AM

Hello.

I have not seen this problem myself and I don't know the cause of it. You might want to try different settings in your Game graphics options and Graphics driver options (NVIDIA or AMD). Please reply here with your solution once you found the cause.

Posted by: Leikeze Oct 14 2019, 13:03 PM

Have you tried disabling heat effects?

Many players experience a black screen when viewing Microwave tanks on Win10 until they disable heat effects in graphics options.

Posted by: OlegBB Oct 14 2019, 18:28 PM

Yes , i tried disabled all effects .

i did not change any setting on my nvidia card .

I playing now on full hd only 1920*1080 - have not seen problem yet .
But on resolution 2560*1440 (2k) - very often (also with disabled effects )

Posted by: Leikeze Oct 15 2019, 00:27 AM

Does your setup necessitate running ZH at 2560*1440 (2k) screen resolution?

Posted by: OlegBB Oct 15 2019, 07:10 AM

no it is not necessitate but if game provide this option why not ? smile.gif

Posted by: Leikeze Oct 15 2019, 11:57 AM

That is my thinking as well.

Have there been any changes to software or hardware since you began playing ZH, prior to this bug appearing?

Posted by: xezon Oct 15 2019, 19:53 PM

Uh guess what...

Attached Image

Posted by: Leikeze Oct 15 2019, 20:01 PM

Wow!

I also met some people complaining of black screen in GameRanger, but the issues were not all the same, as I linked them to this topic to make sure.

Posted by: xezon Oct 15 2019, 20:30 PM

QUOTE(Leikeze @ Oct 15 2019, 22:01 PM) *

Wow!

I also met some people complaining of black screen in GameRanger, but the issues were not all the same, as I linked them to this topic to make sure.

Only happened once. I was cheating camera to higher value and then it snapped black.

Posted by: OlegBB Oct 17 2019, 14:43 PM

Same black screen happened on Full HD for now sad.gif . i making zoom in on camera on black screen after that back to normal . If zoom out - back to black screen and stayed with black screen due to many units on screen . So it's not related to resolution

Posted by: xezon Oct 19 2019, 08:35 AM

What height did you set camera to?

Posted by: OlegBB Oct 21 2019, 17:35 PM

QUOTE(xezon @ Oct 19 2019, 08:35 AM) *

What height did you set camera to?


i am using default camera height . i did not change it

Posted by: xezon Oct 21 2019, 18:56 PM

Ok. How often does this issue happen on your machine? Does it also happen without GenTool + high resolution + higher view?

Posted by: OlegBB Oct 22 2019, 06:10 AM

QUOTE(xezon @ Oct 21 2019, 18:56 PM) *

Ok. How often does this issue happen on your machine? Does it also happen without GenTool + high resolution + higher view?

as i remember game without gentool does not support resolution like full HD or higher. So i install gentool by default smile.gif . How oftern - almost every game if have on screen menu units on one place.

Posted by: xezon Oct 22 2019, 06:53 AM

QUOTE(OlegBB @ Oct 22 2019, 08:10 AM) *

as i remember game without gentool does not support resolution like full HD or higher. So i install gentool by default smile.gif . How oftern - almost every game if have on screen menu units on one place.

Could you try to disable 3D Shadows in the options menu and then try again?

Posted by: Goldjunge Oct 22 2019, 19:15 PM

I'm not sure...does it make any difference to play or watch ZH with 2k in comparsion to Full HD ?

I think it's a Camera Issue. Because i only know this Phenomenon by Maximum Zoom In.
I would do some Experiments with the Camera Height in the Gentool Menu.
Here are also some useful Idea's.
http://www.wsgf.org/dr/command-conquer-generals









Posted by: OlegBB Oct 28 2019, 08:26 AM

Hi all

look like i found cause off black screen issue.

It cause by "Mirowave tank" with heat effect enabled.


Once Mirowave tank spawn from warfactory screen go black even i have only this one unit on my screen.

With disabled heat effects all works good even on 2k resolution and more than 5 Mirowave tanks on screen and a lot of others units on screen and map .

Also i tested all other unit from different nations - no one provide this black screen bug , just MW tank.

Also black screen will gone after MW tanks wil be destroed


Attached thumbnail(s)
Attached Image

Posted by: xezon Oct 28 2019, 08:59 AM

QUOTE(OlegBB @ Oct 28 2019, 10:26 AM) *

It cause by "Mirowave tank" with heat effect enabled.
Once Mirowave tank spawn from warfactory screen go black even i have only this one unit on my screen.

With disabled heat effects all works good even on 2k resolution and more than 5 Mirowave tanks on screen and a lot of others units on screen and map .


Thank you Oleg. I added this information to the http://bit.ly/gentoolfaq

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)